Error message

I shot my house and when I import the images into stitch it gives me this error message:

Error" could not load stitch project at ( where is located on my hard drive ) Reason, the selection folder does not seem to contain data from the ims camera system.

What am I doing wrong. I copy and save the folder from the usb drive to a folder I have set up. Then import to stitch.

Any help would be appreciated.


This sounds like the issue I have with my MacBook.
Are you putting the file on the hard drive or an external drive?
(perhaps put it directly on your desktop while you are processing then move it to the file once it is complete)
Stitch does not seem to like external drives.
If you close stitch and open it again, it should be fine.
Is it a MacBook?

I had the same issue. It’s been awhile, actually back when I did my first one, so I can’t remember exactly what the issue was. I think the problem is the opposite of what @peter.molloy10 said and you need to take it off the desktop and put it in a folder inside your directory.


I tried to replicate the issue, but I can’t—I know I had the same issue with the very first practice run on my house. My projects open from the desktop and an external drive. Just move the file to a different location and see what happens.


The project name is the address of my house. Within that folder there are 4 files, main floor, project, survery log and system. Are all 4 of these to import into stitch or just the mainfloor that has all the scans?

You only need to navigate to and open the main folder, not any of the internal folders.

I have an external hard drive and transfered the files to that. I tried importing and it worked. What is up with that? Does that mean I have to have to put everything on that hard drive? Not sure I want to do that.


No it does not.

Basically it’s a permissions issue.

This morning I looked back at the iGuide Forum conversation I was a part of about this issue and found out what was going on. Turns out I was attempting to open my iGuide project from the desktop and Stitch didn’t have permission to open files from the desktop.

So, basically the data is there, you just need to change the permissions for the file to open the project. Stitch may throw up a dialogue box to ask you to grant permission, like it did to me the other night when I attempted to replicate the issue from my external drive, or you may try putting the data in a sub folder on your hard drive.

If you are on a Mac—go to ‘get info’ on the folder and make sure permissions are set for Stitch to open the folder.

is there a way to grant permission to stitch to allow it to open those files? When you say move to a sub folder, what exactly does that mean? I created a folder under iguide, with a folder in it with the project name ( which the address ). Is that what you mean?


This thread is making the process sound far more complicated than it is in reality. I’ve never had an issue with opening data in Stitch. No permissions, no jumping through hoops – nothing like that.

If someone is running into issues with that then it’s a networking or file sharing issue – not a Stitch or iGuide issue. I recall that in the past someone was trying to open files on a Time Machine backup device and ran into issues. I’m not a Mac guy but it seems like that’s something you shouldn’t do.

Copy the entire data folder from the flash drive to a hard drive and open the copy in Stitch. In my experience, it doesn’t matter if it’s an internal drive, external drive, networked drive, DAS or NAS, etc. As long as you as the drive is property configured, you shouldn’t have an issue.

1 Like


You are not having the same issue becasue you are not on a Mac.

As you said, it’s not complicated, and you are right, it is not a Stitch issue. What’s happening is, for some reason the Mac is not giving Stitch permission to open the file. I had the same issue when trying to open my first project from the desktop. Once I put the file into a folder on my directory, not on my desktop, I was fine. Don’t know why, never had the issue with other apps. I’ve no longer had the issue now that Stitch has permission, from desktop or external.

The other day when this issue came up for someone else, I tried to replicate the issue. From Stitch I navigated to a project on my external drive and got a diologue box asking me to give Stitch permission to access my external drive, which I did.

Again, don’t know why, never happened before. So, ghost in the machine or whatever, but ultimately it comes down to permissions.


@charris Pretty much.

iGuide Projects > {project name]

That should work. If not, go to [get info] on the folder and make sure the permissions are set to [read & write] for all.

Screen Shot 2022-09-01 at 2.15.12 PM


I’m on a MacBook M1Pro and prior to that on a M1 Mac Mini and never had those happen. For what it’s worth.

I have a folder called Iguide on my desktop, yes desktop. Inside it I have a Working folder and a Completed folder. I insert the thumb drive, find the project folders and copy ONLY the projects folders to the Working folder on the desktop.
Open Stitch and point to a project name and open.
Never asked about permissions or had issues opening.
It’s pretty simple

1 Like


Like I said, I have no idea why my Mac asked for permission, it just did, though I have no ongoing issues. I’ve also seen this issue asked about on a FB group so others are having similar experiences.

It’s pretty scary to get a message saying no data exists after completing a project.


If you’re still having difficulties, consider going to ‘System Preferences’ → ‘Security & Privacy’ → ‘Privacy’ → ‘Files and Folders’ in order to grant Stitch necessary permissions.

I would advise against allowing Read & Write permissions for ‘everyone’ as @Jarid suggested, though I appreciate his willingness to help! Doing so could pose a security risk.

If you have any other issues or need further assistance, please create a Support Ticket. Thanks!

1 Like

Thanks @Evan. I forgot about that method. I’ve seen others post on FB groups about this issue and your solution is the more elegant one.


I have not had a chance to try that yet Evan. Thanks

You are not having the same issue becasue you are not on a Mac.

Possibly, but the concept of permissions is the same regardless of the OS. If I copy data to a location that I don’t have read/write access to (say, a NAS device) then I’ll run into problems regardless of whether I’m using Windows, Mac, Linux or something else.

That’s odd that files on your desktop wouldn’t have full permissions by default. That sure sounds like a ghost-in-the-machine issue. :slightly_smiling_face:

I suspect something else is confounding accessing files from a desktop for others. It really should be as simple as opening a folder.

1 Like